I thought we'd stopped adding tests with "bugXXXXX" in the name and tried to
give the test a descriptive name and we were trying not to add more
tests to tests/shaders, but put them in tests/spec/. So maybe rename
it to something like:
tests/spec/glsl-1.10/compiler/post-increment-in-array-size.shader_test

Or whatever you think is better (I'm just reading the bug and trying to come up
with something).

Otherwise this test looks good, so with the rename:
Reviewed-by: Dylan Baker <dy...@pnwbakers.com>

Quoting Tapani Pälli (2018-08-09 23:12:44)
> Signed-off-by: Tapani Pälli <tapani.pa...@intel.com>
> Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=98699
> ---
>  tests/shaders/glsl-compiler-bug98699.vert | 9 +++++++++
>  1 file changed, 9 insertions(+)
>  create mode 100644 tests/shaders/glsl-compiler-bug98699.vert
> 
> diff --git a/tests/shaders/glsl-compiler-bug98699.vert 
> b/tests/shaders/glsl-compiler-bug98699.vert
> new file mode 100644
> index 000000000..9bd219cf0
> --- /dev/null
> +++ b/tests/shaders/glsl-compiler-bug98699.vert
> @@ -0,0 +1,9 @@
> +// [config]
> +// expect_result: fail
> +// glsl_version: 1.10
> +// [end config]
> +
> +void main()
> +{
> +        float[a+++4 ? 1:1] f;
> +}
> -- 
> 2.14.4
> 
> _______________________________________________
> Piglit mailing list
> Piglit@lists.freedesktop.org
> https://lists.freedesktop.org/mailman/listinfo/piglit

Attachment: signature.asc
Description: signature

_______________________________________________
Piglit mailing list
Piglit@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/piglit

Reply via email to