> Don't forget about the new .name, and I thought I might mention that
> preg()/PCREs would be the way to go if you're trying to make your code
> readable.

That's why we have the remark statement (e.g. to make unclear code more readable).

It is always a good habit to frequently comment your code,
in order to set the water level mark. Just an simple example
from my own code commenting habit:


int cASC::SetToken(char *pzToken, int nField)
{
  // Don't try to understand this! I don't
  // understand it my self - it just works...

  int nTokenReference = 0;
  sCONTEXT *psTmp;

  if (bLocked) {
    return -1;
  }

  if (psContext) {
    psTmp = new sCONTEXT[nNumFields+1];

   [...]

bool cASC::Prepare(char *pzToken)
{
  bPrepared = false;
  
  if (bLocked) {
    //oFetchToken.Clone(pzToken);

    // This is were some magic happens
    for (int nField=0; nField<nNumFields; nField++) {
      if (psContext[nField].oFieldData == pzToken/*oFetchToken()*/) {

   [...]


bool cASC::Prepare(int nToken)
{
  bPrepared = false;

  // More magic
  if (bLocked && nToken >= 0 && nToken < nNumFields) {
    nCurrentToken = nToken;
    bPrepared = true;

   [...]

-- 
PHP Windows Mailing List (http://www.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to