> On 5 Jul 2018, at 09:40, Guillermo Polito <guillermopol...@gmail.com> wrote:
> 
> Hi Dario,
> 
> Have you defined those methods in the class side?
> 
>       a) propertyAt: aKey ifAbsent: aBlock
>                ^ self properties at: aKey ifAbsent: aBlock
>       b) propertyAt: aKey ifAbsentPut: aBlock
>                ^ self properties at: aKey ifAbsentPut: aBlock
>       c) propertyAt: aKey put: aValue
>                ^ self properties at: aKey put: aValue
> 
> I will let Marcus answer more properly but I think you should rename those 
> methods to not collapse with the behaviour in the base class...
> 

Yes, we added a general property API to classes. This is used for e.g. tagging 
classes when they are obsolete (instead of relying in the name).

It can be used for other things, too. (the same as we have a property API on 
CompiledMethod, first class Variables and AST Nodes).

        Marcus

Reply via email to