I try to avoid ifs altogether. Most of the time I use polymorphism , which means instead of checking you preform no check and just call a method, depending on the object the method of the same name will have different code which replaces ifs and is far more readable. Of course this technique can replace while loops, switches , even for loops.
Obviously though there will be times you will have to use an if, in that case I prefer ifEmpty: , compatibility is not an issue since Smalltalk allows you to override and insert your custom methods to existing objects with ease. Those techniques are also available in Python. Though in the case of python people love ifs and you rarely see coders take advantages of OOP.