On Fri, Oct 21, 2016 at 10:03 AM, Robert Haas <robertmh...@gmail.com> wrote: > On Thu, Oct 20, 2016 at 3:46 PM, Tom Lane <t...@sss.pgh.pa.us> wrote: >> I'm mostly with Stephen on this. As the names stand, they encourage >> people to go look at the documentation, >> https://www.postgresql.org/docs/devel/static/storage-file-layout.html >> which will provide more information than you'd ever get out of any >> reasonable directory name. > > Well, we could change them all to pg_a, pg_b, pg_c, pg_d, ... which > would encourage that even more strongly. But I don't think that > proposal can be taken seriously. Giving things meaningful names is a > good practice in almost every case.
Moving on with the topic of this thread... I would think that "pg_xact" is what we are moving to rename pg_clog. On top of that, after reading the thread, here are the options and binaries that could be renamed for consistency with the renaming of pg_xlog: - pg_xlogdump -> pg_waldump - pg_resetxlog -> pg_resetwal - pg_receivexlog -> pg_receivewal - initdb --xlogdir -> --waldir - pg_basebackup --xlogmethod --xlogdir -> --walmethod --waldir That's quite a number, and each change is trivial. Previous options would be better kept for backward-compatibility. Personally, I see no urge in changing all that and I am fine with just renaming the *log directories of PGDATA for this thread. But as the point has been raised, here are all things that could be done. -- Michael -- Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-hackers