I wrote: > - List *ri_WithCheckOptions; > - List *ri_WithCheckOptionExprs; > + List *ri_InsertedCheckClauses; > + List *ri_InsertedCheckClauseExprs;
> The distinction between a "clause" and an "expr" is not very obvious, > and certainly most other places in the code use those terms pretty > interchangeably, so I find both the old and new names unclear here. > How about ri_InsertedCheckClauseStates instead for the second list? > And similarly if you're using "Expr" to mean ExprState anywhere else. Actually ... does struct ResultRelInfo need to carry the original WCO clauses at all, rather than just the exprstate list? In most places we do not store expr and exprstate lists in the same node in the first place, so we can get away with using the same field name for corresponding lists in plan and planstate nodes. That's why we don't already have a convention like "fooStates" for such lists. Another thought is that as long as these are lists specifically of WithCheckOption nodes, and not arbitrary expressions, "clause" isn't an especially good term for them; it implies generality that isn't there. And CheckClauses invites confusion with, for example, CHECK clauses of domain types. So maybe better names would be "ri_InsertedCheckOptions" (and "ri_InsertedCheckOptionStates" if you still need that). Or maybe "ri_InsertedWCOClauses" and "ri_InsertedWCOClauseStates". I'm less sure about whether this is an improvement, though. regards, tom lane -- Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-hackers