On 2015-09-04 16:26, Alexander Korotkov wrote:
Attached patch is implementing this. It doesn't pretend to be fully
correct implementation, but it should be enough for proof the concept.
In this patch access method exposes another function: amvalidate. It
takes data structure representing opclass and throws error if it finds
it invalid.
This method is used on new opclass definition (alter operator family
etc. are not yet implemented but planned). Also, there is SQL function
validate_opclass(oid) which is used in regression tests.
Any thoughts?
This is starting to look good.
However I don't like the naming differences between validate_opclass and
amvalidate. If you expect that the current amvalidate will only be used
for opclass validation then it should be renamed accordingly.
Also GetIndexAmRoutine should check the return type of the amhandler.
--
Petr Jelinek http://www.2ndQuadrant.com/
PostgreSQL Development, 24x7 Support, Training & Services
--
Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org)
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-hackers