On Sat, Jan 17, 2015 at 11:06 PM, Robert Haas <robertmh...@gmail.com> wrote:
> On Fri, Jan 16, 2015 at 10:56 AM, Alvaro Herrera
> <alvhe...@2ndquadrant.com> wrote:
>> So how about something like
>>
>> #define ALLOCFLAG_HUGE                  0x01
>> #define ALLOCFLAG_NO_ERROR_ON_OOM       0x02
>> void *
>> MemoryContextAllocFlags(MemoryContext context, Size size, int flags);
>
> That sounds good, although personally I'd rather have the name be
> something like MemoryContextAllocExtended; we have precedent for using
> "Extended" for this sort of thing elsewhere.  Also, I'd suggest trying
> to keep the flag name short, e.g. ALLOC_HUGE and ALLOC_NO_OOM (or
> ALLOC_SOFT_FAIL?).
Yes, I think that this name makes more sense (LockAcquire[Extended],
RangeVarGetRelid[Extended]), as well as minimizing shorter name for
the flags.
-- 
Michael


-- 
Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org)
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-hackers

Reply via email to