On Sun, Jun 30, 2013 at 1:08 PM, Pavel Stehule <pavel.steh...@gmail.com> wrote: > 2013/6/30 Gurjeet Singh <gurj...@singh.im>: >> On Sun, Jun 30, 2013 at 11:46 AM, Pavel Stehule <pavel.steh...@gmail.com> >> wrote: >>> >>> 2013/6/30 Gurjeet Singh <gurj...@singh.im>: >>> > On Sun, Jun 30, 2013 at 11:13 AM, Pavel Stehule >>> > <pavel.steh...@gmail.com> >>> > wrote: >>> > >>> > How about naming those 3 variables as follows: >>> > >>> > root_expr_kind >>> > root_expr_name >>> > root_bool_expr_type >>> >>> +1 >> >> >> Thanks. Attached is the patch with that change. I'll update the commitfest >> entry with a link to this email. > > ok > > I chechecked it - patched without warnings, all tests passed > > It is ready for commit
I think it's a waste of code to try to handle bushy trees. A list is not a particularly efficient representation of the pending list; this will probably be slower than recusing in the common case. I'd suggest keeping the logic to handle left-deep trees, which I find rather elegant, but ditching the pending list. -- Robert Haas EnterpriseDB: http://www.enterprisedb.com The Enterprise PostgreSQL Company -- Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-hackers