https://commitfest.postgresql.org/action/patch_view?id=300
Why did you add to_string() and to_array() functions though we already have string_to_array() and array_to_string() functions? I prefer adding three arguments version of string_to_array() instead of to_array(). Please notice me if you think to_string() and to_array() are better names for the feature. For example, compatibility for other databases. * string_to_array( str text, sep text, nullstr text DEFAULT NULL ) is compatible with the existing string_to_array( str, sep ), and "nullstr => 'NULL'" will be same as your to_array(). * array_to_string( arr anyarray, sep text, nullstr text DEFAULT NULL ) is compatible with the existing array_to_string(); separator also ignored when nullstr is NULL. "nullstr => ''" (an empty string) will be same as your to_array(). -- Itagaki Takahiro -- Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-hackers