On Sun, Sep 27, 2009 at 11:54 AM, Robert Haas <robertmh...@gmail.com> wrote: > > If this patch looks good now, can you mark it Ready for Committer in > the CommitFest app? If there are any remaining issues, please post a > further review. >
while i'm not the reviewer this patch doesn't apply cleanly anymore... some comments: 1) in docs for REVOKE you're omitting the SCHEMA part of the new syntax. 2) i think that getNamespacesObjectsOids() could be rewritten in something like: + { + List *objects = NIL; + ListCell *cell; + char *nspname; + Oid namespaceId; + + foreach(cell, nspnames) + { + List *relations = NIL; + + nspname = strVal(lfirst(cell)); + namespaceId = LookupExplicitNamespace(nspname); + switch (objtype) + { + /* do what you need for every type of object here */ + + } i think this is more readable -- Atentamente, Jaime Casanova Soporte y capacitación de PostgreSQL Asesoría y desarrollo de sistemas Guayaquil - Ecuador Cel. +59387171157 -- Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-hackers