> > For an insert with many columns or with large value this syntax can > significantly improve readability. So it wasn't invented here, so > what? I don't see a downside to allowing this syntax other than MySQL > used it first, and there are multiple upsides (readability, easier > transitions). >
Insert of too much columns is signal, so your database is badly designed. If you afraid about readability, you can you named parameters - I hope so this feature will be early committed. It can look like: CREATE OR REPLACE FUNCTION insert_tab(p1 varchar = NULL, p2 varchar = NULL, p3 varchar = NULL, ... RETURNS void AS $$ INSERT INTO tab(p1,p2,p3,p4.... VALUES($1,$2,$3,$4, ... then you can call this procedure SELECT insert_tab(10 as p1, 20 as p3); regards Pavel Stehule > -- > Rob Wultsch > wult...@gmail.com > -- Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-hackers