On Fri, Sep 24, 2021 at 3:42 PM Tom Lane <t...@sss.pgh.pa.us> wrote: > Robert Haas <robertmh...@gmail.com> writes: > > I like this patch. > > I think the basic idea is about right, but I'm not happy with the > three-way delayChkpt business; that seems too cute by three-quarters. > I think two independent boolean flags, one saying "I'm preventing > checkpoint start" and one saying "I'm preventing checkpoint completion", > would be much less confusing and also more future-proof. Who's to say > that we won't ever need both states to be set in the same process?
Nobody, but the version of the patch that I was looking at uses a separate bit for each one: +/* symbols for PGPROC.delayChkpt */ +#define DELAY_CHKPT_START (1<<0) +#define DELAY_CHKPT_COMPLETE (1<<1) One could instead use separate Booleans, but there doesn't seem to be anything three-way about this? -- Robert Haas EDB: http://www.enterprisedb.com