On Wed, Apr 7, 2021 at 12:07 AM Mahendra Singh Thalor <mahi6...@gmail.com> wrote: > +++ b/src/backend/storage/page/bufpage.c > @@ -51,7 +51,7 @@ PageInit(Page page, Size pageSize, Size specialSize) > /* Make sure all fields of page are zero, as well as unused space */ > MemSet(p, 0, pageSize); > > - p->pd_flags = 0; > + /* p->pd_flags = 0; done by above MemSet */ > > I think, for readability we can keep old code here or we can remove > new added comment also.
Setting p->pd_flags = 0; is unnecessary and redundant after memsetting the page to zeros. Also, see the existing code for pd_prune_xid, similarly I've done that for pd_flags. I think it's okay with /* p->pd_flags = 0; done by above MemSet */. > Apart from this, all other changes looks good to me. Thanks for taking a look at the patch. With Regards, Bharath Rupireddy. EnterpriseDB: http://www.enterprisedb.com