Hi I tried this patch out last year but was overrolled by Other Stuff before I got around to providing any feedback, and was reminded of it just now when I was trying to execute "\df somefunction text int" or similar, which had me confused until I remembered it's not a feature yet, so it would certainly be very welcome to have this.
2020年11月3日(火) 23:27 Greg Sabino Mullane <htamf...@gmail.com>: > > Thanks for looking this over! > >> >> some Abbreviations of common types are not added to the type_abbreviations[] >> Such as: >> >> Int8 => bigint > > > I wasn't aiming to provide a canonical list, as I personally have never seen > anyone use int8 instead of bigint when (for example) creating a function, but > I'm not strongly opposed to expanding the list. I have vague memories of working with "int8" a bit (possibly related to an Informix migration), anyway it seems easy enough to add them for completeness as someone (possibly migrating from another database) might wonder why it's not working. Just a small code readability suggestion - in exec_command_d(), it seems neater to put the funcargs declaration in a block together with the code with which uses it (see attached diff). Regards Ian Barwick -- EnterpriseDB: https://www.enterprisedb.com
diff --git a/src/bin/psql/command.c b/src/bin/psql/command.c index d449cea66c..e8c1fd64bc 100644 --- a/src/bin/psql/command.c +++ b/src/bin/psql/command.c @@ -781,8 +781,6 @@ exec_command_d(PsqlScanState scan_state, bool active_branch, const char *cmd) case 'f': /* function subsystem */ switch (cmd[2]) { - char *funcargs; - case '\0': case '+': case 'S': @@ -791,10 +789,14 @@ exec_command_d(PsqlScanState scan_state, bool active_branch, const char *cmd) case 'p': case 't': case 'w': + { + char *funcargs; + funcargs = psql_scan_slash_option(scan_state, OT_WHOLE_LINE, NULL, true); success = describeFunctions(&cmd[2], pattern, show_verbose, show_system, funcargs); free(funcargs); break; + } default: status = PSQL_CMD_UNKNOWN; break;