Kyotaro Horiguchi <horikyota....@gmail.com> writes: > At Tue, 14 Apr 2020 16:32:40 -0400, Tom Lane <t...@sss.pgh.pa.us> wrote in > + stby->is_sync_standby = true; /* might change below */
> I'm uneasy with that. In quorum mode all running standbys are marked > as "sync" and that's bogus. I don't follow that? The existing coding of SyncRepGetSyncStandbysQuorum returns all the candidates in its list, so this is isomorphic to that. Possibly a different name for the flag would be more suited? > On the other hand sync_standbys is already sorted in priority order so I > think we can get rid of the member by setting *am_sync as the follows. > SyncRepGetSyncRecPtr: > if (sync_standbys[i].is_me) > { > *am_sync = (i < SyncRepConfig->num_sync); > break; > } I disagree with this, it will change the behavior in the quorum case. In any case, a change like this will cause callers to know way more than they ought to about the ordering of the array. In my mind, the fact that SyncRepGetSyncStandbysPriority is sorting the array is an internal implementation detail; I do not want it to be part of the API. (Apropos to that, I realized from working on this patch that there's another, completely undocumented assumption in the existing code, that the integer list will be sorted by walsender index for equal priorities. I don't like that either, and not just because it's undocumented.) regards, tom lane