Alvaro Herrera <alvhe...@2ndquadrant.com> writes: > This very small patch removes some duplicated code in pg_publication.
Seems like the extra test on missing_oid is unnecessary: + oid = get_publication_oid(pubname, missing_ok); + if (!OidIsValid(oid) && missing_ok) + return NULL; As coded, it's get_publication_oid's job to deal with that. Otherwise +1 regards, tom lane