On Fri, Nov 15, 2019 at 2:00 AM [email protected]
<[email protected]> wrote:
>
> Actually I also don't have strong opinion but I thought someone would
> complain about renaming of those columns and also some tools like monitoring
> which use those columns will not work. If we use {total, min, max, mean,
> stddev}_time, someone might mistakenly understand {total, min, max, mean,
> stddev}_time mean {total, min, max, mean, stddev} of planning and execution.
> If I need to choose {total, min, max, mean, stddev}_time or {total, min, max,
> mean, stddev}_exec_time, I choose former one because choosing best name is
> not worth destructing the existing scripts or tools.
We could definitely keep (plan|exec)_time for the SRF, and have the
{total, min, max, mean, stddev}_time created by the view to be a sum
of planning + execution for each counter, and it doesn't sound like a
bad idea if having even more columns in the view is not an issue.