On Sat, Sep 21, 2019 at 6:01 PM Amit Kapila <amit.kapil...@gmail.com> wrote:
> On Fri, Jun 7, 2019 at 12:03 PM Masahiko Sawada <sawada.m...@gmail.com> > wrote: > > > > Since the previous version patch conflicts with current HEAD, I've > > attached the updated version patches. > > > > Review comments: > ------------------------------ > Sawada-San, are you planning to work on the review comments? I can take care of this and then proceed with further review if you are tied up with something else. > * > +/* > + * DSM keys for parallel lazy vacuum. Unlike other parallel execution > code, > + * since we don't need to worry about DSM keys conflicting with > plan_node_id > + * we can use small integers. > + */ > +#define PARALLEL_VACUUM_KEY_SHARED 1 > +#define PARALLEL_VACUUM_KEY_DEAD_TUPLES 2 > +#define PARALLEL_VACUUM_KEY_QUERY_TEXT 3 > > I think it would be better if these keys should be assigned numbers in > a way we do for other similar operation like create index. See below > defines > in code: > /* Magic numbers for parallel state sharing */ > #define PARALLEL_KEY_BTREE_SHARED UINT64CONST(0xA000000000000001) > > This will make the code consistent with other parallel operations. > I think we don't need to handle this comment. Today, I read the other emails in the thread and noticed that you have done this based on comment by Robert and that decision seems wise to me. -- With Regards, Amit Kapila. EnterpriseDB: http://www.enterprisedb.com