On Fri, 27 Sep 2019 at 23:21, Robert Haas <robertmh...@gmail.com> wrote: > > On Fri, Sep 27, 2019 at 12:41 PM Amit Khandekar <amitdkhan...@gmail.com> > wrote: > > Preferably I want wait_for_xmins() to get rid of the $node parameter, > > because we can deduce it using slot name. But that requires having > > get_node_from_slotname(). Your suggestion was to remove > > get_node_from_slotname() and add back the $node param so as to reduce > > duplicate code. Instead, how about keeping wait_for_xmins() in the > > PostgresNode.pm() ? This way, we won't have duplication, and also we > > can get rid of param $node. This is just my preference; if you are > > quite inclined to not have get_node_from_slotname(), I will go with > > your suggestion. > > I'd be inclined not to have it. I think having a lookup function to > go from slot name -> node is strange; it doesn't really simplify > things that much for the caller, and it makes the logic harder to > follow. It would break outright if you had the same slot name on > multiple nodes, which is a perfectly reasonable scenario.
Alright. Attached is the updated patch that splits the file into two files, one that does only xmin related testing, and the other test file that tests conflict recovery scenarios, and also one scenario where drop-database drops the slots on the database on standby. Removed get_slot_xmins() and get_node_from_slotname(). Renamed 'replica' to 'standby'. Used node->backup() function instead of pg_basebackup command. Renamed $master_slot to $master_slotname, similarly for $standby_slot. -- Thanks, -Amit Khandekar EnterpriseDB Corporation The Postgres Database Company
logicaldecodng_standby_v3.tar.gz
Description: GNU Zip compressed data