Hi, On 2019-05-20 13:25:52 +1200, Thomas Munro wrote: > In PostgreSQL, it's always inner = right, outer = left. You can see > that reflected in plannodes.h and elsewhere: > > /* ---------------- > * these are defined to avoid confusion problems with "left" > * and "right" and "inner" and "outer". The convention is that > * the "left" plan is the "outer" plan and the "right" plan is > * the inner plan, but these make the code more readable. > * ---------------- > */ > #define innerPlan(node) (((Plan *)(node))->righttree) > #define outerPlan(node) (((Plan *)(node))->lefttree)
I really don't understand why we don't just rename those fields. Greetings, Andres Freund