> On 18 Aug 2026, at 17:10, Aleksander Alekseev <[email protected]> 
> wrote:

> 1. I found a write-only field ArchiveHandle.lookaheadSize which can
> safely be removed.
> 2. I found magic constants 512 which should be replaced with TAR_BLOCK_SIZE.

Might be a nitpick, but I'm not sure that using TAR_BLOCK_SIZE is preferred for
a lookahead buffer used to identify the archive format where tar is just one of
the options.

I would be more inclined to initialize .lookaheadSize like today and then use
that instead of the hardcoded 512.  Having a buffer in ArchiveHandle without
knowing the size of it does seem like a bad practice even if nothing uses it
today.

--
Daniel Gustafsson



Reply via email to