On Tue, Aug 18, 2026 at 1:37 PM Michael Paquier <[email protected]> wrote:
>
> On Mon, Aug 17, 2026 at 01:05:22PM +0900, Michael Paquier wrote:
> > The nested calls in hstore_out() feel a bit inelegant as well written
> > this way.  Something in sequential form would feel much easier to
> > parse, with one line for each add_size involved.
>
> Cleaned up a bit all that, and applied on HEAD.

Hi.

https://git.postgresql.org/cgit/postgresql.git/commit/?id=92e20d4a4382810a30bdb394473d6ee891edab73

The consensus seems favoring "size_t" over "Size" for new code, see [1], [2],
though this doesn't appear to be documented anywhere.

[1]: https://www.postgresql.org/message-id/688312.1782222788%40sss.pgh.pa.us
[2]: 
https://www.postgresql.org/message-id/CANWCAZZJxgDAUsBK-1CctczwTz2TVo3TzjhhSD7fAA9EWte3eA%40mail.gmail.com


--
jian
https://www.enterprisedb.com/


Reply via email to