Thanks for reviewing! Em qui., 2 de jan. de 2025 às 13:16, Kirill Reshke <reshkekir...@gmail.com> escreveu: > > However, this: > > >- if (skip_option == SKIP_PAGES_ALL_FROZEN) > >- { > >- if ((mapbits & VISIBILITYMAP_ALL_FROZEN) != 0) > >- continue; > >- } > >- > >- if (skip_option == SKIP_PAGES_ALL_VISIBLE) > >- { > >- if ((mapbits & VISIBILITYMAP_ALL_VISIBLE) != 0) > >- continue; > >- } > > changes to this > (in heapam_read_stream_next_block) > >+ > >+ if ((p->skip_option == SKIP_PAGES_ALL_FROZEN && (mapbts & > >VISIBILITYMAP_ALL_FROZEN) != 0) || > >+ (p->skip_option == SKIP_PAGES_ALL_VISIBLE && (mapbts & > >VISIBILITYMAP_ALL_VISIBLE) != 0)) > > + continue; > > I don't understand this change. The patch aims to be purely applying > streaming API, not refactoring. And if we refactor this code, this is > less readable than it was.
Yeap, I agree. Attached a v2 fixed. -- Matheus Alcantara
v2-0001-Use-read-stream-on-amcheck.patch
Description: Binary data