Nathan Bossart <nathandboss...@gmail.com> writes: > Here's what I have staged for commit.
In addition to Alvaro's comments: +/* special must-be-first options for dispatching to various subprograms */ +typedef enum Subprogram +{ + SUBPROGRAM_CHECK, + ... etc "Subprogram" doesn't quite seem like the right name for this enum. These are not subprograms, they are options. I'm not feeling especially inventive today, so this might be a lousy suggestion, but how about typedef enum DispatchOption { DISPATCH_CHECK, ... etc Also, I think our usual convention for annotating a special last entry is more like + SUBPROGRAM_SINGLE, + SUBPROGRAM_POSTMASTER, /* must be last */ +} Subprogram; I don't like the comment with "above" because it's not very clear above what. regards, tom lane