On Wed, Mar 6, 2024 at 6:59 PM Masahiko Sawada <sawada.m...@gmail.com> wrote: > > > + /* Find the control object in shared memory */ > > + control = handle; > > I think it's mostly because of readability; it makes clear that the > handle should be castable to dsa_pointer and it's a control object. I > borrowed it from dshash_attach().
I find that a bit strange, but I went ahead and kept it. On Wed, Mar 6, 2024 at 9:13 PM Masahiko Sawada <sawada.m...@gmail.com> wrote: > The 0001 patch looks good to me. I have some minor comments: > +PGFILEDESC = "test_radixtree - test code for src/backend/lib/radixtree.c" > + > > "src/backend/lib/radixtree.c" should be updated to > "src/include/lib/radixtree.h". Done. > --- /dev/null > +++ b/src/test/modules/test_radixtree/README > @@ -0,0 +1,7 @@ > +test_integerset contains unit tests for testing the integer set > implementation > +in src/backend/lib/integerset.c. > + > +The tests verify the correctness of the implementation, but they can also be > +used as a micro-benchmark. If you set the 'intset_test_stats' flag in > +test_integerset.c, the tests will print extra information about execution > time > +and memory usage. > > This file is not updated for test_radixtree. I think we can remove it > as the test cases in test_radixtree are clear. Done. I pushed this with a few last-minute cosmetic adjustments. This has been a very long time coming, but we're finally in the home stretch! Already, I see sifaka doesn't like this, and I'm looking now...