On Wed, Mar 6, 2024 at 8:25 PM John Naylor <johncnaylo...@gmail.com> wrote: > > Actually, I forgot -- I had one more question: Masahiko, is there a > reason for this extra local variable, which uses the base type, rather > than the typedef'd parameter? > > +RT_SCOPE RT_RADIX_TREE * > +RT_ATTACH(dsa_area *dsa, RT_HANDLE handle) > +{ > + RT_RADIX_TREE *tree; > + dsa_pointer control; > + > + tree = (RT_RADIX_TREE *) palloc0(sizeof(RT_RADIX_TREE)); > + > + /* Find the control object in shared memory */ > + control = handle;
I think it's mostly because of readability; it makes clear that the handle should be castable to dsa_pointer and it's a control object. I borrowed it from dshash_attach(). Regards, -- Masahiko Sawada Amazon Web Services: https://aws.amazon.com