> On 26 Feb 2024, at 19:56, Jacob Champion <jacob.champ...@enterprisedb.com> 
> wrote:

>> + * SASL_FAILED: The exchance has failed and the connection should be
> 
> s/exchance/exchange/

I rank that as one of my better typos actually. Fixed though.

>> - if (final && !done)
>> + if (final && !(status == SASL_FAILED || status == SASL_COMPLETE))
> 
> Since there's not yet a SASL_ASYNC, I wonder if this would be more
> readable if it were changed to
>    if (final && status == SASL_CONTINUE)
> to match the if condition shortly after it.

Fair point, that's more readable in this commit.

> In 0002, at the beginning of pg_SASL_init, the `password` variable now
> has an uninitialized code path. The OAuth patchset initializes it to
> NULL:

Nice catch, fixed.

--
Daniel Gustafsson

Attachment: v2-0001-Refactor-SASL-exchange-to-return-tri-state-status.patch
Description: Binary data

Attachment: v2-0002-Explicitly-require-password-for-SCRAM-exchange.patch
Description: Binary data

Reply via email to