On 08.01.24 16:06, Peter Eisentraut wrote:
On 08.01.24 15:04, Aleksander Alekseev wrote:
[...] so I quickly wrote some (wrong) instrumentation to try to test
your patch.
Yep, it confused me too at first.
Since the encoding happens right before exit() call, maybe it's worth
changing $b in-place in order to make the code slightly more readable
for most of us :)
My patch originally had the old-style
my $b_escaped = $b;
$b_escaped =~ s/.../;
... sprintf(..., $b_escaped);
but then I learned about the newish /r modifier and thought it was
cooler. :)
committed