In SlruSharedData, a new comment is added that starts: "Instead of global counter we maintain a bank-wise lru counter because ..." You don't need to explain what we don't do. Just explain what we do do. So remove the words "Instead of a global counter" from there, because they offer no wisdom. Same with the phrase "so there is no point to ...". I think "The oldest page is therefore" should say "The oldest page *in the bank* is therefore", for extra clarity.
I wonder what's the deal with false sharing in the new bank_cur_lru_count array. Maybe instead of using LWLockPadded for bank_locks, we should have a new struct, with both the LWLock and the LRU counter; then pad *that* to the cacheline size. This way, both the lwlock and the counter come to the CPU running this code together. Looking at SlruRecentlyUsed, which was a macro and is now a function. The comment about "multiple evaluation of arguments" no longer applies, so it needs to be removed; and it shouldn't talk about itself being a macro. Using "Size" as type for bank_mask looks odd. For a bitmask, maybe it's be more appropriate to use bits64 if we do need a 64-bit mask (we don't have bits64, but it's easy to add a typedef). I bet we don't really need a 64 bit mask, and a 32-bit or even a 16-bit is sufficient, given the other limitations on number of buffers. I think SimpleLruReadPage should have this assert at start: + Assert(LWLockHeldByMe(SimpleLruGetSLRUBankLock(ctl, pageno))); Do we really need one separate lwlock tranche for each SLRU? -- Álvaro Herrera Breisgau, Deutschland — https://www.EnterpriseDB.com/ "Cuando mañana llegue pelearemos segun lo que mañana exija" (Mowgli)