On Wed, Mar 8, 2023 at 8:24 AM wangw.f...@fujitsu.com <wangw.f...@fujitsu.com> wrote: > > Attach the new patch. >
I think this combines multiple improvements in one patch. We can consider all of them together or maybe it would be better to split some of those. Do we think it makes sense to split some of the improvements? I could think of below: 1. Remove SyncRepRequested() check from WalSndUpdateProgress(). 2. Add check of wal_sender_timeout > 0 in WalSndUpdateProgress() and any other similar place. 3. Change the name of ProcessPendingWrites() to WalSndSendPending(). 4. Change WalSndUpdateProgress() to WalSndUpdateProgressAndKeepalive(). 5. The remaining patch. Now, for (1), we can consider backpatching but I am not sure if it is worth it because in the worst case, we will miss sending a keepalive. For (4), it is not clear to me that we have a complete agreement on the new name. Andres, do you have an opinion on the new name used in the patch? If we agree that we don't need to backpatch for (1) and the new name for (4) is reasonable then we can commit 1-4 as one patch and then look at the remaining patch. Thoughts? -- With Regards, Amit Kapila.