Hi, During a recent code review, I was confused multiple times by the toptxn member of ReorderBufferTXN, which is defined only for sub-transactions.
e.g. txn->toptxn member == NULL means the txn is a top level txn. e.g. txn->toptxn member != NULL means the txn is not a top level txn It makes sense if you squint and read it slowly enough, but IMO it's too easy to accidentally misinterpret the meaning when reading code that uses this member. ~ Such code can be made easier to read just by introducing some simple macros: #define isa_toptxn(rbtxn) (rbtxn->toptxn == NULL) #define isa_subtxn(rbtxn) (rbtxn->toptxn != NULL) #define get_toptxn(rbtxn) (isa_subtxn(rbtxn) ? rbtxn->toptxn : rbtxn) ~ PSA a small patch that does this. (Tests OK using make check-world) Thoughts? ------ Kind Regards, Peter Smith. Fujitsu Australia
v1-0001-Add-macros-for-ReorderBufferTXN-toptxn.patch
Description: Binary data