On Tue, Dec 13, 2022 at 2:24 AM Alvaro Herrera <alvhe...@alvh.no-ip.org> wrote: > On 2022-Dec-12, Amit Langote wrote: > > I started feeling like putting all the new logic being added > > by this patch into plancache.c at the heart of GetCachedPlan() and > > tweaking its API in kind of unintuitive ways may not have been such a > > good idea to begin with. So I started thinking again about your > > GetRunnablePlan() wrapper idea and thought maybe we could do something > > with it. Let's say we name it GetCachedPlanLockPartitions() and put > > the logic that does initial pruning with the new > > ExecutorDoInitialPruning() in it, instead of in the normal > > GetCachedPlan() path. Any callers that call GetCachedPlan() instead > > call GetCachedPlanLockPartitions() with either the List ** parameter > > as now or some container struct if that seems better. Whether > > GetCachedPlanLockPartitions() needs to do anything other than return > > the CachedPlan returned by GetCachedPlan() can be decided by the > > latter setting, say, CachedPlan.has_unlocked_partitions. That will be > > done by AcquireExecutorLocks() when it sees containsInitialPrunnig in > > any of the PlannedStmts it sees, locking only the > > PlannedStmt.minLockRelids set (which is all relations where no pruning > > is needed!), leaving the partition locking to > > GetCachedPlanLockPartitions(). > > Hmm. This doesn't sound totally unreasonable, except to the point David > was making that perhaps we may want this container struct to accomodate > other things in the future than just the partition pruning results, so I > think its name (and that of the function that produces it) ought to be a > little more generic than that. > > (I think this also answers your question on whether a List ** is better > than a container struct.)
OK, so here's a WIP attempt at that. I have moved the original functionality of GetCachedPlan() to GetCachedPlanInternal(), turning the former into a sort of controller as described shortly. The latter's CheckCachedPlan() part now only locks the "minimal" set of, non-prunable, relations, making a note of whether the plan contains any prunable subnodes and thus prunable relations whose locking is deferred to the caller, GetCachedPlan(). GetCachedPlan(), as a sort of controller as mentioned before, does the pruning if needed on the minimally valid plan returned by GetCachedPlanInternal(), locks the partitions that survive, and redoes the whole thing if the locking of partitions invalidates the plan. The pruning results are returned through the new output parameter of GetCachedPlan() of type CachedPlanExtra. I named it so after much consideration, because all the new logic that produces stuff to put into it is a part of the plancache module and has to do with manipulating a CachedPlan. (I had considered CachedPlanExecInfo to indicate that it contains information that is to be forwarded to the executor, though that just didn't seem to fit in plancache.h.) I have broken out a few things into a preparatory patch 0001. Mainly, it invents PlannedStmt.minLockRelids to replace the AcquireExecutorLocks()'s current loop over the range table to figure out the relations to lock. I also threw in a couple of pruning related non-functional changes in there to make it easier to read the 0002, which is the main patch. -- Thanks, Amit Langote EDB: http://www.enterprisedb.com
v29-0001-Preparatory-refactoring-before-reworking-CachedP.patch
Description: Binary data
v29-0002-In-GetCachedPlan-only-lock-unpruned-partitions.patch
Description: Binary data