On Sun, Dec 4, 2022 at 4:48 PM houzj.f...@fujitsu.com <houzj.f...@fujitsu.com> wrote: > > On Friday, December 2, 2022 4:59 PM Peter Smith <smithpb2...@gmail.com> wrote: > > > > > ~~~ > > > > 12. pa_clean_subtrans > > > > +/* Reset the list that maintains subtransactions. */ void > > +pa_clean_subtrans(void) > > +{ > > + subxactlist = NIL; > > +} > > > > Maybe a more informative function name would be pa_reset_subxactlist()? > > I thought the current name is more consistent with pa_start_subtrans. >
Then how about changing the name to pg_reset_subtrans()? > > > > > 21. apply_worker_clean_exit > > > > I wasn't sure if calling this a 'clean' exit meant anything much. > > > > How about: > > - apply_worker_proc_exit, or > > - apply_worker_exit > > I thought the clean means the exit number is 0(proc_exit(0)) and is > not due to any ERROR, I am not sure If proc_exit or exit is better. > > I have addressed other comments in the new version patch. > +1 for apply_worker_exit. One minor suggestion for a recent change in v56-0001*: /* - * A hash table used to cache streaming transactions being applied and the - * parallel application workers required to apply transactions. + * A hash table used to cache the state of streaming transactions being + * applied by the parallel apply workers. */ static HTAB *ParallelApplyTxnHash = NULL; -- With Regards, Amit Kapila.