Nathan Bossart <nathandboss...@gmail.com> writes: > On Fri, Oct 07, 2022 at 03:34:51PM +0900, Michael Paquier wrote: >> Thanks. I would perhaps use names less generic than role{1,2,3} for >> the roles or "role1" for the database name, but the logic looks >> sound.
> Here is a new version with more descriptive role names. There's another problem there, which is that buildfarm animals using -DENFORCE_REGRESSION_TEST_NAME_RESTRICTIONS will complain about role names that don't start with "regress_". regards, tom lane