On 2022-Mar-19, Tomas Vondra wrote: > @@ -174,7 +182,13 @@ ALTER PUBLICATION noinsert SET (publish = 'update, > delete'); > <para> > Add some tables to the publication: > <programlisting> > -ALTER PUBLICATION mypublication ADD TABLE users, departments; > +ALTER PUBLICATION mypublication ADD TABLE users (user_id, firstname), > departments; > +</programlisting></para> > + > + <para> > + Change the set of columns published for a table: > +<programlisting> > +ALTER PUBLICATION mypublication SET TABLE users (user_id, firstname, > lastname), TABLE departments; > </programlisting></para> > > <para>
Hmm, it seems to me that if you've removed the feature to change the set of columns published for a table, then the second example should be removed as well. > +/* > + * Transform the publication column lists expression for all the relations > + * in the list. > + * > + * XXX The name is a bit misleading, because we don't really transform > + * anything here - we merely check the column list is compatible with the > + * definition of the publication (with publish_via_partition_root=false) > + * we only allow column lists on the leaf relations. So maybe rename it? > + */ > +static void > +TransformPubColumnList(List *tables, const char *queryString, > + bool pubviaroot) > +{ I agree with renaming this function. Maybe CheckPubRelationColumnList() ? -- Álvaro Herrera PostgreSQL Developer — https://www.EnterpriseDB.com/ "This is a foot just waiting to be shot" (Andrew Dunstan)