> @@ -2142,7 +2142,8 @@ static struct config_int ConfigureNamesInt[] = > {"post_auth_delay", PGC_BACKEND, DEVELOPER_OPTIONS, > - gettext_noop("Waits N seconds on connection startup > after authentication."), > + gettext_noop("Sets the amount of time to wait on > connection " > + "startup after > authentication."),
> @@ -2762,7 +2763,8 @@ static struct config_int ConfigureNamesInt[] = > {"pre_auth_delay", PGC_SIGHUP, DEVELOPER_OPTIONS, > - gettext_noop("Waits N seconds on connection startup > before authentication."), > + gettext_noop("Sets the amount of time to wait on > connection " > + "startup before > authentication."), > gettext_noop("This allows attaching a debugger to the > process."), I wonder if these should say "Sets the amount of time to wait [before] authentication during connection startup" > {"checkpoint_warning", PGC_SIGHUP, WAL_CHECKPOINTS, > - gettext_noop("Enables warnings if checkpoint segments > are filled more " > - "frequently than this."), > + gettext_noop("Sets the maximum time before warning if > checkpoints " > + "triggered by WAL volume > happen too frequently."), > gettext_noop("Write a message to the server log if > checkpoints " > - "caused by the filling of > checkpoint segment files happens more " > + "caused by the filling of WAL > segment files happen more " > "frequently than this number > of seconds. Zero turns off the warning."), Should this still say "seconds" ? Or change it to "this amount of time"? I'm not sure. > {"log_rotation_age", PGC_SIGHUP, LOGGING_WHERE, > - gettext_noop("Automatic log file rotation will occur > after N minutes."), > + gettext_noop("Sets the amount of time to wait before > forcing " > + "log file rotation."), > NULL, > GUC_UNIT_MIN > }, > @@ -3154,7 +3159,8 @@ static struct config_int ConfigureNamesInt[] = > > { > {"log_rotation_size", PGC_SIGHUP, LOGGING_WHERE, > - gettext_noop("Automatic log file rotation will occur > after N kilobytes."), > + gettext_noop("Sets the maximum size of log file to > reach before " > + "forcing log file rotation."), Actually, I think that for log_rotation_size, it should not say "forcing". "Sets the maximum size a log file can reach before being rotated" BTW the EXPLAIN flag for enable_incremental_sort could be backpatched to v13. -- Justin