> [ shrug... ]  This is just a variant of the choose-a-new-function-name
> game.  If we are going to choose a new function name, choosing one that
> collides with an existing name (obsolete or not) doesn't seem like a
> win to me.  You could just as well choose another name, and avoid
> angering whoever out there might still be using timenow().

Agreed.  It looks like finding a good name for this function would in
fact be the hardest part of adding it ... the namespace for now()-like
functions is quite cluttered.

I'd be inclined to go with "gettime()", but I'm certainly open to suggestions.

> BTW: at least with our current interpretation of these datatypes, the
> only type that is sensible for a now()-like function to return is
> timestamptz.  Not plain timestamp; that cannot be considered to
> represent a well-defined instant at all.

True.

---------------------------(end of broadcast)---------------------------
TIP 4: Have you searched our list archives?

               http://archives.postgresql.org

Reply via email to