An alternative, though I'm not sure it's better in any way :

DELETE FROM generators WHERE started + '30 minutes'::interval <= now();

-Mitch

----- Original Message -----
From: "Paul Tomblin" <[EMAIL PROTECTED]>
To: <[EMAIL PROTECTED]>
Sent: Sunday, July 08, 2001 2:12 PM
Subject: [GENERAL] How should I phrase this?


> I've got a table that I insert a value and a timestamp "now()".  Then I
> want to delete entries that are older than 30 minutes old.  After some
> experimentation, I found the following works, but it looks awkward and
> backwards.  Is there a better, more readable way of phrasing this or
> rewriting it?
>
> DELETE
> FROM           generators
> WHERE          age(now(),started) > interval '30 minutes'
>
>
> --
> Paul Tomblin <[EMAIL PROTECTED]>, not speaking for anybody
> "Nobody can be told what the dominatrix is, they have to see it for
themselves"
>
> ---------------------------(end of broadcast)---------------------------
> TIP 5: Have you checked our extensive FAQ?
>
> http://www.postgresql.org/users-lounge/docs/faq.html
>


---------------------------(end of broadcast)---------------------------
TIP 5: Have you checked our extensive FAQ?

http://www.postgresql.org/users-lounge/docs/faq.html

Reply via email to