Rename varatt_external to varatt_external_oid

This impacts a few more definitions, related to this structure, as of:
- VARTAG_ONDISK -> VARTAG_ONDISK_OID
- TOAST_POINTER_SIZE -> TOAST_OID_POINTER_SIZE
- TOAST_MAX_CHUNK_SIZE -> TOAST_OID_MAX_CHUNK_SIZE
- Macros in varatt.h for varatt_external_oid.

This rename is part of a conversation to add support for more types of
external TOAST pointers, not only OID.  One of them is to extend the
pointers to use an OID8 variant.  The control file field for the max
chunk size is left out, for now.

Author: Michael Paquier <[email protected]>
Reviewed-by: Chao Li <[email protected]>
Reviewed-by: Yugo Nagata <[email protected]>
Reviewed-by: Bharath Rupireddy <[email protected]>
Discussion: 
https://postgr.es/m/CALj2ACVnO6jjs5aRx3dSOBy9LV7=iakpbr1eovoeb8rl8q4...@mail.gmail.com
Discussion: https://postgr.es/m/[email protected]

Branch
------
master

Details
-------
https://git.postgresql.org/pg/commitdiff/c5806f2165b57434290dd345ba301e4179634c23

Modified Files
--------------
contrib/amcheck/verify_heapam.c                 | 14 +++++-----
doc/src/sgml/storage.sgml                       |  2 +-
src/backend/access/common/detoast.c             | 30 ++++++++++-----------
src/backend/access/common/toast_compression.c   |  6 ++---
src/backend/access/common/toast_internals.c     | 16 +++++------
src/backend/access/heap/heaptoast.c             |  2 +-
src/backend/access/table/toast_helper.c         |  4 +--
src/backend/access/transam/xlog.c               |  8 +++---
src/backend/replication/logical/reorderbuffer.c |  6 ++---
src/backend/utils/adt/varlena.c                 |  2 +-
src/bin/pg_resetwal/pg_resetwal.c               |  2 +-
src/include/access/detoast.h                    |  4 +--
src/include/access/heaptoast.h                  |  6 ++---
src/include/varatt.h                            | 36 ++++++++++++++-----------
src/tools/pgindent/typedefs.list                |  2 +-
15 files changed, 72 insertions(+), 68 deletions(-)

Reply via email to