postgres_fdw: Rename option "restore_stats" to "import_stats".
The option added by commit 28972b6fc was named "restore_stats", because it was calling pg_restore_relation_stats()/pg_restore_attribute_stats() in place of fetching a remote rowsample. However, those code paths have been replaced with calls to import_relation_statistics()/import_attribute_statistics() (cf. commit 54cd6fc83), so the option is now slightly misnamed. Switch the option to "import_stats", which more closely reflects both the functions being called internally, and the user's perception of what the operation is doing. Back-patch to v19 where commit 28972b6fc went in. Suggested-by: Etsuro Fujita <[email protected]> Author: Corey Huinker <[email protected]> Discussion: https://postgr.es/m/CADkLM%3DezuspTk3VD-2EM6XtFP-Dfz7cJKtnbn0cB6gocsAgu1g%40mail.gmail.com Backpatch-through: 19 Branch ------ master Details ------- https://git.postgresql.org/pg/commitdiff/9a08585e8e59068d0ede7d47cd037915a42e1362 Modified Files -------------- contrib/postgres_fdw/expected/postgres_fdw.out | 6 +++--- contrib/postgres_fdw/option.c | 8 ++++---- contrib/postgres_fdw/postgres_fdw.c | 16 ++++++++-------- contrib/postgres_fdw/sql/postgres_fdw.sql | 6 +++--- doc/src/sgml/postgres-fdw.sgml | 6 +++--- 5 files changed, 21 insertions(+), 21 deletions(-)
