Shorten pg_attribute_always_inline to pg_always_inline

The pg_attribute_always_inline macro name is so long it forces pgindent
to format the code in strange ways. Which may incentivize patch authors
to either structure the code in strange ways (e.g. reorder prototypes),
use shorter names, etc. Neither is very desirable for code readability.

This shortens the name by removing the _attribute_ part. It also makes
it more consistent with pg_noinline, which does not have the _attribute_
part either.

Backpatched to all supported branches, to prevent conflicts when
backpatching other fixes. The backbranches however keep both the old and
new macro name, so that existing code keeps working.

Author: Andres Freund <[email protected]>
Reviewed-by: Peter Geoghegan <[email protected]>
Reviewed-by: Tomas Vondra <[email protected]>
Discussion: 
https://postgr.es/m/bqqdehahpoa36igpictuqyn2s2mexk3t3ehidh2ffd2slb35e5@rzgksuiszgbg
Backpatch-through: 14

Branch
------
REL_18_STABLE

Details
-------
https://git.postgresql.org/pg/commitdiff/d1d9688b1f92590110cb868ce4f65f39da0af2a8

Modified Files
--------------
src/backend/access/heap/heapam.c      |  2 +-
src/backend/access/transam/xlog.c     |  4 +--
src/backend/commands/copyfromparse.c  | 26 ++++++++---------
src/backend/commands/copyto.c         |  4 +--
src/backend/executor/execExprInterp.c | 54 +++++++++++++++++------------------
src/backend/executor/execTuples.c     |  6 ++--
src/backend/executor/nodeHashjoin.c   |  2 +-
src/backend/nodes/queryjumblefuncs.c  |  6 ++--
src/backend/storage/buffer/bufmgr.c   | 14 ++++-----
src/backend/utils/adt/json.c          |  2 +-
src/backend/utils/cache/catcache.c    |  2 +-
src/include/c.h                       |  9 +++++-
src/include/executor/execScan.h       | 18 ++++++------
13 files changed, 78 insertions(+), 71 deletions(-)

Reply via email to