Thus it was written in the epistle of Dave Hartnoll,
> > Oh, one other tweak. The RFC proposes to overload next
> > to mean "fall through to the next case". I don't think
> > this is wise, since we'll often want to use loop controls
> > within a switch statement. Instead, I think we should
> > use skip to do that. (To be read as "Skip to the next
> > statement.")
> 
> I would like to suggest a different keyword that does not imply some
> `jumping' action. For years, I have used `nobreak' in my C code when I want
> to indicate that a case fall-through is intentional:
> 
>     #define nobreak
> 
>     switch(...) {
>        case 1:  ...;
>                    nobreak;  /* intentional fall-through */
>        case 2: ...;
>                    break;
>        case 3: ...;
>     }
> 
> Does anyone agree that `nobreak' reads much better than `skip'?

"skip" was uncomfortable when I read it (I at first took it to mean "skip over
the following" rather than "skip to the following"), but I find "nobreak" also
a bit strange.  How about "proceed"?

Ted
-- 
Ted Ashton ([EMAIL PROTECTED]) | From the Tom Swifty collection:
Southern Adventist University    | "I'm knitting a sweater for my guppy", said
Deep thought to be found at      | Tom wolfishly.
http://www.southern.edu/~ashted  |

Reply via email to