Graham Barr wrote:
> On Mon, Jan 21, 2002 at 03:58:49PM -0500, Michael G Schwern wrote:

Case 1:
> >     do {
> >         if my $foo = bar() {
> >             ...
> >         }
> >     }

Case 2:
>   if ((my $foo = bar()) eq 'foo') {
>     ...
>   }
> 
>   if ($foo eq 'bar') {
>     ...
>   }

Despite fear of joining in a religious argument, to me Case 1 above is much
more painful (both in readability and typing) than fixing Case 2 with a
single line would be.

More importantly, named arguments in subroutines would break lexical scoping
according to the "only inside the braces" definition. IMHO, what we
sacrifice (larger private scope + maintainability + paramed subs...) seems
more dear than what we gain (parsing purity?).

Regards,
Michael Percy

Reply via email to