In writing up the RFC on removing/fixing $[line noise here] variables,
I've decided to leave out the following suggestion:
On Tue, Aug 01, 2000 at 06:47:41PM -0700, Nathan Wiger wrote:
> Alan Burlison wrote:
> >
> > Steve Simmons wrote:
> >
> > > I'd prefer that we break these vars out into a set of hashes with
> > > appropriate names:
> > >
> > > $PERL_CORE{warnings} vs $^W
> > > $PERL_CORE{version} vs $^V
> > > $PERL_FORMATS{name} vs $^
> > > $PERL_FORMATS{lines_left} vs $-
> >
> > Hmm - I quite like this. I'd like it even more if they were package
> > scoped and/or localisable. My choice of warning level in my package
> > shouldn't affect your choice in your package.
>
> Now *that's* an advantage I like! Being able to turn on certain warnings
> just for certain packages (rather than just a global all-or-nothing $^W)
> would be really cool.
>
> As for nitty-gritty, I like the $PERL::CORE::Warnings or
> $perl::core::warnings syntax others have mentioned a little better.
The renaming to use hashes or module-form variables is not intended
to *change* the meanings of the variables, it's an attempt to seize
the opportunity to go to a more rational naming structure. The
scoped/localizable use of those variables would potentially be a
major change. Rather than mix them together, I'd prefer to see
scoping/localizing broken out into a separate RFC. Have at it, folks. :-)