>I'd either leave that as (localtime)[3,4,5] (please read the man page for >Time::Object), or understand that there's absolutely no need to separate >off the variables like that in an object oriented interface: > my ($day, $month, $year) = (localtime)[3,4,5]; >becomes: > my $date = localtime; >And use $date->day (or month or year) later when you need to. But people *like* to be able to put things in simple variables. It's more convenient to type $day than $date->day for repeated usage. --tom
- Re: date interface (was Re: perl6 req... Simon Cozens
- wantarray() should be named wantlist() (was R... Tad McClellan
- Re: wantarray() should be named wantlist(... Jonathan Scott Duff
- Re: wantarray() should be named wantl... Clayton Scott
- Re: wantarray() should be named ... Jonathan Scott Duff
- Re: wantarray() should be na... Nathan Wiger
- Re: wantarray() should be na... skud
- Re: wantarray() should be named wantlist(... Graham Barr
- Re: wantarray() should be named wantlist() (... Damian Conway
- Re: wantarray() should be named wantlist(... Tad McClellan
- Re: date interface (was Re: perl6 requirements, o... Tom Christiansen
- Re: date interface (was Re: perl6 requirement... Matt Sergeant
- Re: date interface (was Re: perl6 requirements, on boo... Damian Conway