Thomas Wittek wrote:
Larry Wall schrieb:
> I think the ¥ and Y operators are going to have to change to something else.
Very probably I missed something as I'm only a distant observer of the
Perl6 development: Why not just call it "zip"?!
There is a function called zip, wouldn't it be possible to create an
operator with the same name?
zip(@a; @b) -> function
@a zip @b -> operator
Or would that lead to grammar ambiguities, that are impossible to resolve?
more generally, could we say that any function that has no parameters
other than a list - i.e., :(*@) - automatically gets a list-infix
operator form as well? e.g.:
my sub zip([EMAIL PROTECTED]) { ... }
could be called with
zip (@a; @b; @c)
or
@a zip @b zip @c
--
Jonathan "Dataweaver" Lang