Patrick R. Michaud wrote:
... get_argc (which perhaps should be called something
else)
Better names are welcome.
So, all we really need is something that can tell us how many :optional
arguments were filled in.
Sounds reasonable.
op optional_count(out INT)
Another question: do we want two distinct opocdes:
- get_args: (or optional_count) of this subroutine (valid throughout the
whole sub)
- get_retc: current result count of the *recent* function return
or should we have just one opcode like now, that holds only the state of
the recent call/return?
Pm
leo