On Wed, May 11, 2005 at 09:19:50AM +0200, Leopold Toetsch wrote:
> We should just have:
>   x = getattribute o, "x"
> and the set equivalent:
>   setattribute o, "x", x

I would much prefer this.  I don't have much problem with 
grabbing and using the offsets, but at the moment they're 
really only useful as a speed optimization when accessing
more than a couple of attributes, and then only for the
duration of a subroutine.  For accessing a single attribute,

   x = getattribute o, "MyClass\x0$.x"

or (better)

   x = getattribute o, "x"

is far superior.

Pm

Reply via email to