It is and it isn't. The naming conventions say that struct Parrot_Interp should really be struct parrot_interp_t, but that's a ginormous global change. I've tried to implement it once or twice, but my most recent attempt cause mysterious compile errors.
I've prepared a patch for it. make realclean && perl ./Configure.pl && make && make fulltest passed without errors or additional warnings. (i686; SuSE Linux 9.0)
Wow. Excellent.
You're welcome to try it again, though...while you're at it, you might as well make all internal Parrot functions take an Interp * instead of a struct Parrot_Interp *. That ought to save us a couple kilobytes.
What files are "internal"? I can change this, too.
I believe that any function that takes 'struct Parrot_Interp *' currently should really be taking 'Interp *'. Any function that takes the 'Parrot_Interp' typedef should be left alone.
-- Brent "Dax" Royal-Gordon <[EMAIL PROTECTED]> Perl and Parrot hacker
Oceania has always been at war with Eastasia.